Assertion failed: Argument tnsnamesOraTemplate must point to an existing file

Question

Hello SAP Guru’s

Here i am stuck in middle of installation and getting the below error ๐Ÿ™

Linux RHEL 7.3
Oracle 12c
SAP SOLMAN 7.2 ABAP

Standard System > Standard System( Last error reported by the step: Assertion failed: OraNetworkConfigurator.doClientNetworkConfiguration: Argument tnsnamesOraTemplate must point to an existing file

I have given Full permission (0777) to SWPM

Set umask 022

and re-run ./sapinst and still getting the same error.

Here is the oracle environment

S01:oras01 31> cd /oracle/
client/ oraInventory/ S01/ stage/
S01:oras01 31> env
TERM=xterm-256color
HOME=/home/oras01
SHELL=/bin/csh
USER=oras01
LOGNAME=oras01
PATH=/oracle/S01/121/bin:/usr/lib64/qt-3.3/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/usr/sap/S01/SYS/exe/uc/linuxx86_64:/usr/sap/S01/SYS/exe/run:/home/oras01:.
XDG_SESSION_ID=3
XDG_SEAT=seat0
XDG_VTNR=1
HOSTTYPE=x86_64-linux
VENDOR=unknown
OSTYPE=linux
MACHTYPE=x86_64
SHLVL=1
PWD=/oracle/S01/121/dbs
GROUP=dba
HOST=S01
MAIL=/var/spool/mail/oras01
HOSTNAME=S01

QT_PLUGIN_PATH=/usr/lib64/kde4/plugins:/usr/lib/kde4/plugins
LANG=en_US.UTF-8
LESSOPEN=||/usr/bin/lesspipe.sh %s
MODULESHOME=/usr/share/Modules
MODULEPATH=/usr/share/Modules/modulefiles:/etc/modulefiles
LOADEDMODULES=
QT_GRAPHICSSYSTEM_CHECKED=1
QTDIR=/usr/lib64/qt-3.3
QTINC=/usr/lib64/qt-3.3/include
QTLIB=/usr/lib64/qt-3.3/lib
SAPSYSTEMNAME=S01
DIR_LIBRARY=/usr/sap/S01/SYS/exe/run
RSEC_SSFS_DATAPATH=/usr/sap/S01/SYS/global/security/rsecssfs/data
RSEC_SSFS_KEYPATH=/usr/sap/S01/SYS/global/security/rsecssfs/key
rsdb_ssfs_connect=1
LD_LIBRARY_PATH=/usr/sap/S01/SYS/exe/run:/usr/sap/S01/SYS/exe/uc/linuxx86_64:/oracle/S01/121/lib
SAPEXE=/usr/sap/S01/SYS/exe/run
THREAD=NOPS
DB_SID=S01
dbms_type=ORA
dbs_ora_tnsname=S01
dbs_ora_schema=SAPSR3
ORACLE_SID=S01
ORACLE_HOME=/oracle/S01/121
NLS_LANG=AMERICAN_AMERICA.UTF8
SAPDATA_HOME=/oracle/S01
ORACLE_BASE=/oracle/S01

—————————–

SWPM

/root/Desktop/SWPM/COMMON/INSTALL/ORA

777 Permission to tns (whole SWPM Folder)

TNSNAMES.ORA

################
# Filename……: tnsnames.ora
# Created…….: created by SAP AG, R/3 Rel. >= 6.10
# Name……….:
# Date……….:
# @(#) $Id: //inst/inst_scripts/lmts_006_REL/tpls/ora/TNSNAMES.ORA#1 $
################

@DB_SID@.@DOMAIN@=
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS =
(COMMUNITY = SAP.@DOMAIN@)
(PROTOCOL = @PROTOCOL_TCP@)
(HOST = @HOST@)
(PORT = @PORT@)
)
)
(CONNECT_DATA =
(@SERVICE_NAME@ = @DB_SID@)
(GLOBAL_NAME = @GLOBAL_NAME@)
)
)

——————————————————–

-rwxrwxr-x. 1 s01adm dba 501 Jun 11 05:22 tnsnames.ora

S01:oras01 46> pwd
/oracle/S01/12102/network/admin
S01:oras01 47> cat tnsnames.ora
################
# Filename……: tnsnames.ora
# Created…….: created by SAP AG, R/3 Rel. >= 6.10
# Name……….:
# Date……….:
# @(#) $Id: //inst/inst_scripts/lmts_006_REL/tpls/ora/TNSNAMES.ORA#1 $
################
S01.WORLD=
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS =
(COMMUNITY = SAP.WORLD)
(PROTOCOL = TCP)
(HOST = S01)
(PORT = 1521)
)
)
(CONNECT_DATA =
(SID = S01)
(GLOBAL_NAME = S01.WORLD)
)
)
S01:oras01 48>

Please check and let me know your advise as how should i proceed.

Thanks

Abhishek

Hello SAP Guru's Here i am stuck in middle of installation and getting the below error ๐Ÿ™ Linux RHEL 7.3 Oracle 12c SAP SOLMAN 7.2 ABAP Standard System > Standard System( Last error reported by the step: Assertion failed: OraNetworkConfigurator.doClientNetworkConfiguration: Argument tnsnamesOraTemplate must point to an existing file I have given Full permission (0777) to SWPM Set umask 022 and re-run ./sapinst and still getting the same error. Here is the oracle environment S01:oras01 31> cd /oracle/ client/ oraInventory/ S01/ stage/ S01:oras01 31> env TERM=xterm-256color HOME=/home/oras01 SHELL=/bin/csh USER=oras01 LOGNAME=oras01 PATH=/oracle/S01/121/bin:/usr/lib64/qt-3.3/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/usr/sap/S01/SYS/exe/uc/linuxx86_64:/usr/sap/S01/SYS/exe/run:/home/oras01:. XDG_SESSION_ID=3 XDG_SEAT=seat0 XDG_VTNR=1 HOSTTYPE=x86_64-linux VENDOR=unknown OSTYPE=linux MACHTYPE=x86_64 SHLVL=1 PWD=/oracle/S01/121/dbs GROUP=dba…

User Rating: Be the first one !
in progress 0
2 months 0 Answers 42 views 0

Answers ( No )

  1. HI James,

    Thanks for your response, here is the SWPM Level

    Manifest-Version: 1.0
    # HEADER keyname: SWPM  keyvendor: sap.com keylocation: SAP SE supportpackage: 20
    # ASSEMBLY SECTION assembly time: 2017-5-22 2:26:53  delivery package: lkg_swpm code line: LMTS_006_REL platform: LINUX_X86_64 label: IND:SLTOOLSET:1.0:SWPM:*:LINUX_X86_64:* compilation mode: dbg
    # LATEST CHANGE LIST latest change list of control file: 171092 latest change list of product.catalog: 171092
    # SAPINST FRAMEWORK SAPinst framework release: 749.0.22

    Let me know how can i fix this issue.

    Regards

    Abhishek Verma

  2. Hi Abhishek, This is swpm bug, are you using the latest swpm? Best regards, James